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Typography means more than bringing order to the
passing on of information; it means elevating to the sublime
the mould in which the process of passing on is cast.

Frank E. Blokland

Limited user rights
You may never use DTL font production software to edit data of which
you do not own the rights, including but not limited to intellectual property
rights, copyright and trademark rights, unless the rightful claimant has
given his written and signed consent.
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Export...
The export of the OpenType layout tables from a font opened in oT™ has
been much improved. As described on page 10 of the DTL OTMaster
manual, dumping of the binary layout tables involves interpretation. Also
on the same page of the manual one can read that the oT™ 2.3 useris ‘[...]
advised to read and possibly correct exported feature files, especially if a font’s
layout behavior is complex: OTMaster’s AFDKO-syntax dump is not perfect yet'.

In 0TM 2.4 the interpretation of the OpenType layout tables has been
meliorated and editing is not required anymore; the exported features can
be read-in without any alterations. And although the way the exported
features are listed could be different (due to the inevitable interpretation)
from the features-description that was used for generating the font
originally, the functionality should be identical.

feature onum {
sub @FIG_TAB LINING by @FIG FIT OLDSTYLE;
} onum;
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# Feature "onum": Oldstyle Figures
# used in script: latn
# from a lookup of type GSUB_LOOKUP TYPE SINGLE
#‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k‘k*************************‘k‘k‘k*‘k‘k‘k
lookup GSUB_LOOKUP_ 00005
{
lookupflag O;
sub \zero by \zerooldstyle;
sub \one by \oneoldstyle;
sub \two by \twooldstyle;
sub \three by \threeoldstyle;
sub \four by \fouroldstyle;
sub \five by \fiveoldstyle;
sub \six by \sixoldstyle;
sub \seven by \sevenoldstyle;
sub \eight by \eightoldstyle;
sub \nine by \nineoldstyle;
} GSUB_LOOKUP_00005;

Unilities

Feature description as used for
generating the original font data (the
glyph classes are defined in the file

also, of course).

The same feature information as
exported by OTM 2.4.

Choose the Export... function for
exporting OpenType Layout features.

oT™ Y Edit View To

To export the features choose File > Export... and subsequently the
‘Select file to export’ dialog will show up, in which the ‘Adobe FDK feature file
(*fea)’ option can be selected (besides, of course, the target directory).
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B 3% The ‘Select file to export’ dialog.

Where: | #& Snow Leopard

URW 4+ + character layout file (*.cha)

Fliurl ¥ Adobe FDK feature file (*.fea)

Adobe Font Metrics file (*.afm)
URW++ Font Metadata (*.ufm)

..dﬂCE') E'-"Save» 3

w

Next the ‘Feature Export Dialog’ will show up asking which of the tables
present in the font have to be exported.

Feature Export Dialog The ‘Feature Export Dialog’.

Choose which of the existing tables you wish to export:
Export 'BASE' table.
Export 'CDEF' table.

¥ Export 'GPOS' table.

V' Export 'GSUB' table.

¥ Export 'name' table.

Cancel { OK

The exported features files can be modified using a text editor. Altered
features files can be imported via File > Import... function.

Any OpenType layout features file with the AFDKO syntax can be
imported, even if the listed features are not covered by the font’s character
set. The modified Hatch OpenType (‘HOT’) tool will remove the none-
covered features during font generation. Of course, to make all applicable
features work, the character naming convention should be identical in the
font and in the OpenType layout features file.
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One can use the Import... features functionality for instance for the
positioning of marks in Arabic fonts. A standardized features file
containing the necessary information can be imported and subsequently
the mark attachment points can be edited interactively or numerically via
the Tools > ‘GPoS’’GsUB’ Table Viewer for the correct positioning of
the (mark to) marks.

OTM GPOSIGSUB Viewer - AdobeArabic-Regular.otf
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Note on the export of URwW++ Font Metadata (UFM)
The urMm file contains the font metadata information, i.e. info on font
naming and vertical metrics, but also info on matters such as weight, style
and embedding. This text file is used in a FontMaster or IKARUS based
workflow together with a glyph database (BE [Bezier] or 1K [IKARUS]
format), kerning file (BE or kern.fea), PAR file (binary file for the storage of
some additional information) and an OpenType layout features file.

Currently the vertical metrics are recalculated in the exported UFM file
to an em of 15000 units, which is the default for the rkARUS format.
The naming information stored in the exported UFM file is relatively
limited and the name records in the name table can contain (many) more
entries. This limitation can simply be circumvented by first exporting the
OpenType layout features from the font as described above and
subsequently copying the name table information in the UrM file. The only
thing that subsequently has to be changed in the copied name table
information is the ‘nameid’ entry, with which each line starts; this has to be
changed into “TTName’. Any resulting duplicate naming entry in the
original UFM file will be superseded by the info in the “TTName’ string.

Unilities
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Mark positioning can be done
interactively or numerically.
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In the ‘post’ header, the ‘formatType’

Type Name Value Comment .
version number can be changed.
Fixed formatType OxBEO20000 Ox00010000 for version 1.0.
Fixed italicAngle 0.800 [ralic angle in counter-clockwise degrees from the vertical.

FWORD underlinePosition 29
FWORD  underlineThickness 4
ULONG isFixedPitch

ULONG  minMemTyped2

ULONG maxMemType42

ULONG  minMemTypel

ULONG maxMemTypel

Distance top of underline from baseline (negative = below baseline),
Suggested value for the underline thickness.
Set to O if the font is proportionally spaced.
Minimum memory usage when downloaded.
Maximum memory usage when downloaded.

Minimum memory usage when downloaded as a Type 1.

@ @ @ @ @ =

Maximum memary usage when downloaded as a Type 1.

‘post’ table
The post table contains information to enable printing of TrueType fonts
on PostScript-printers. In the post table the formatType entry in the post
header can be changed in 0TM 2.4 from format 2 to format 3 and vice versa.

Changing from format 2 to 3 will remove the post names entries.
Doing the opposite will generate a post table set of glyph names. Also
format 1 and 4 can be entered here, but this will mess up things, while this
function will not re-encode the font in question in any manner.

In the ‘gasp’ header, the table version

Type Name Value Comment number (0 or 1) can be changed.
USHORT wversion 8 Version number (0 = without, 1 = with ClearType).
USHORT numRanges 3 Number of records to follow.
‘gasp’ table

In the gasp table > gasp header the version entry can be changed between o
and 1. As can be read in the OpenType specs, the gasp table ‘[... | contains
information that describes the preferred rasterization techniques for the typeface
when it is rendered on grayscale-capable devices’. In other words, the info in
the gasp table controls the rendering of type on the screen.

There are two table versions, namely ‘0’ and ‘I’. Version number ‘zero’
is the oldest one and controls ‘standard’ grid-fitting in combination with
anti-aliasing. Version ‘one’ enables optimized settings for the ClearType
rasterizer, i.e. it makes tuning for subpixel rendering possible (symmetric
smoothing in combination with symmetric grid fitting).
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oTF Consistency Checker
The oTF Consistency Checker has a new entry, namely Language. This
function can be used to check the coverage by a font of scripts and

languages.
OTM Cansistency Checker - PP22X13T.otf (read only)
OTF Consistency Checker
Header Name  Version  Statistics  Unicode  Code Page  Language
195 languages, 78 complete, 25 faulty, 92 missing Glyph Set: Microsoft; Unicode BMP only
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{ Print Status . ) Print Clyphs . ) PrintMissing .. | ( Check ¥ Uncheck |

To start the function, click on the Check button. On the left half of the
dialog the supported scripts will be listed. Selecting a certain script will
result in a listing of (partly) supported languages. Selecting a language of
which not all characters are covered, will result in a listing of the ones that
are missing.

There are four check boxes which control the forenamed listing:

—hide missing scripts, which result in a listing of only the scripts covered
by the font.

—hide faulty, which will show only the scripts within a script that are
covered for 100 percent. Languages that are completely covered are
indicated by a green ribbon. Languages that are ‘faulty’ are indicated by a
yellow ribbon. Languages that are only partly covered are indicated by a
red ribbon, which has to be interpreted as ‘very faulty’ and these cannot be
hidden with this checkbox.

—hide missing languages, which results in the showing of the languages
within a script which are (partly —depending on the use of the other check
boxes) covered.

—hide complete, which does the opposite of the hide faulty check box.

Fogﬁ»gagter”

The Language entry of the OTF
Consistency Checker.
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OTM Consistency Checker = AXS7C13T.otf (read only)

OTF Consistency Checker :
Header  Name  Version  Statistics  Unicode  Code Page  Language

105 languages, 113 complete, 40 faulty, 42 missing
{_!hide missing scripts_| hide missing languages

" hide faulty " hide complete

Seript / Status
[

Unicode Clyph Mapping: Cyrillic/Abkhazian
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Abkh... 66 of 90 unicodes

&6 of 72 unicodes (91.7%)

Chuv. 70 of 78 unicades

ﬁ ii - ey
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vl L

( Print Status .. ) Print Glyphs . ' Prin Missing .. | ( Check _ Check ) Uncheck

Selecting the Print Status... button will send the current information
(depending on the check box settings) shown on the ‘Script/Language |
Status’ part of the dialog to the selected printer.

Selecting the Print Glyphs... button will send an overview of all the
characters in the font (including info on the Unicode code points) to the

selected printer.

Selecting the Print Missing... button will send an overview of all the

characters missing in the font for a certain language to the selected printer.

Unicode Glyph Mapping: Cyrillic/Abkhazian

Missing unicodes:

0x0494 'R’ (CYRILLIC CAPITAL LETTER GHE WITH MIDDLE HOOK)
0x0495 's' (CYRILLIC SMALL LETTER GHE WITH MIDDLE HOOK)
0x049a 'K' (CYRILLIC CAPITAL LETTER KA WITH DESCENDER)
0x049b 'k’ (CYRILLIC SMALL LETTER KA WITH DESCENDER)
0x049e 'K' (CYRILLIC CAPITAL LETTER KA WITH STROKE)
0x049f 'k' (CYRILLIC SMALL LETTER KA WITH STROKE)

0x04ab6 'Th' (CYRILLIC CAPITAL LETTER PE WITH MIDDLE HOOK)
0x04a7 'm' (CYRILLIC SMALL LETTER PE WITH MIDDLE HOOK)
0x04a8 '@' (CYRILLIC CAPITAL LETTER ABKHASIAN HA)

The language-functionality in the oTF Consistency Checker was partly
based on several sources from the internet, including Michael Everson’s
site The alphabets of Europe (http:/[www.evertype.com/alphabets),
www.geonames.de, www.omniglot.com, and, of course, Wikipedia.

Fogﬁ»gagter”

A listing of supported languages by a
font is presented per script.

An overview of missing glyphs can be
sent to a printer.
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manual:

OpenType s either a registered
trademark or trademark of Microsoft
Corporation in the United States of
America and|or other countries.

PostScript is a registered trademark of
Adobe Systems Incorporated.

TrueType s a trademark of Apple
Computer, Incorporated.

Adobe is a registered trademark of
Adobe Systems Incorporated.

Apple and Macintosh are registered
trademarks of Apple Computer,
Incorporated.

Microsoft and Windows are either
registered trademarks or trademarks
of Microsoft Corporation in the
United States of America and|or other
countries.

Other company, product, and service
names occasionally or incidentally
mentioned in this manual may be
trademarks or service marks of others.



